


<!doctype html>

<html amp lang="en">


<head>
	<meta charset="utf-8">
	<title> AdvanceTC Limited (NSX:A88) Investor Guide Update </title>
    <link rel="canonical" href="https://www.abnnewswire.net/press/en/105409/AdvanceTC-Limited-(NSX-A88)-Investor-Guide-Update.html" />


<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ABN_Newswire" />
<meta name="twitter:creator" content="@ABN_Newswire" /> 
<meta name="twitter:title" content="@ABN_Newswire" /> 
<meta name="twitter:description" content="@ABN_Newswire" />   
<meta name="twitter:image" content="https://media.abnnewswire.net/topimg/en/103331_01_l.jpg" /> 	
<meta name="viewport" content="width=device-width,minimum-scale=1,initial-scale=1">
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto">
    <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
        <!-- Multilanguage Versions of this release -->

<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage":{
    "@type":"WebPage",
    "@id":"https://www.abnnewswire.net/press/en/105409/AdvanceTC-Limited-(NSX-A88)-Investor-Guide-Update.html"
  },
  "headline": "AdvanceTC Limited (NSX:A88) Investor Guide Update",
  "image": {
    "@type": "ImageObject",
    "url": "https://media.abnnewswire.net/topimg/en/103331_01_h.jpg",
    "height": 800,
    "width": 800
  },
  "datePublished": "2021-05-14T15:17:00Z",
  "dateModified": "2021-05-14T15:17:00Z",
  "author": {
    "@type": "Person",
    "name": "Tim Mckinnon"
  },
   "publisher": {
    "@type": "Organization",
    "name": "ABN Newswire",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.abnnewswire.net/images/logos/ABN-LOGOchinese-shadow.png",
      "width": 122,
      "height": 60
    }
  },
  "description": "AdvanceTC Ltd (OTCMKTS:ATCLF) (NSX:A88) is pleased to advise that the Company has released an Investor's Guide with FAQ to better guide Investors with Questions that they may have on the Company."
}
</script>    
    
<style amp-boilerplate>body{-webkit-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-moz-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-ms-animation:-amp-start 8s steps(1,end) 0s 1 normal both;animation:-amp-start 8s steps(1,end) 0s 1 normal both}@-webkit-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-moz-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-ms-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-o-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}</style><noscript><style amp-boilerplate>body{-webkit-animation:none;-moz-animation:none;-ms-animation:none;animation:none}</style></noscript>

     <style amp-custom>
        body {
            margin: 0;
            font-family: 'Roboto', sans-serif;
            background-color: white;
        }

        .brand-logo {
            display: flex;
            align-items: center;
            border: solid #dcdcdc;
            border-width: 1px 0;
            font-family: 'Roboto', sans-serif;
            font-size: .9em;
        }

        .article-image {
            position:relative;

        }

        .article-thumb {
            float:left;
            margin: 5px;
        }

        .widget {
            border: solid #dcdcdc;
            border-width: 1px 0;
            font-family: 'Roboto', sans-serif;
            font-size: .9em;
        }

        .ad-container {
            display: flex;
            justify-content: center;
        }

        .content-container p {
            line-height: 24px;
        }

        .carousel {
            background: #33cccc;
            padding: 15px;
        }

        .carousel_headline {
            background: #ffcccc;
            padding: 10px;
            text-align: center;
        }
        .carousel_image {
            background: #00ffff;
            padding: 0px;
           
                    }

        header,
        .article-body {
            padding: 15px;
        }

        .lightbox {
            background: #222;
        }

        .full-bleed {
            margin: 0 -15px;
        }

        .lightbox-content {
            position: absolute;
            top: 0;
            left: 0;
            right: 0;
            bottom: 0;
            display: flex;
            flex-direction: column;
            flex-wrap: nowrap;
            justify-content: center;
            align-items: center;
        }

            .lightbox-content p {
                color: #fff;
                padding: 15px;
            }

        .lightbox amp-img {
            width: 100%;
        }

        figure {
            margin: 0;
        }

        figcaption {
            color: #6f757a;
            padding: 15px 0;
            font-size: .9em;
        }

        .author {
            display: flex;
            align-items: center;
            background: #f4f4f4;
            padding: 0 15px;
            font-size: .8em;
            border: solid #dcdcdc;
            border-width: 1px 0;
        }

        .header-time {
            color: #a8a3ae;
            font-family: 'Roboto', sans-serif;
            font-size: 12px;
        }

        .author p {
            margin: 5px;
        }

        .byline {
            font-family: 'Roboto', sans-serif;
            display: inline-block;
        }

            .byline p {
                line-height: normal;
            }

            .byline .brand {
                color: #6f757a;
            }

        .standfirst {
            color: #6f757a;
        }

        .mailto {
            text-decoration: none;
        }

        #author-avatar {
            margin: 10px;
            border: 5px solid #fff;
            width: 50px;
            height: 50px;
            border-radius: 50%;
        }

        h1 {
            margin: 5px 0;
            font-weight: normal;
        }

        footer {
            display: flex;
            align-items: center;
            justify-content: center;
            height: 226px;
            background: #f4f4f4;
        }

        hr {
            margin: 0;
        }

        amp-img {
        
            background-color: white;
        }
    </style>
    <script async src="https://cdn.ampproject.org/v0.js"></script>
    <script async custom-element="amp-iframe" src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js"></script>
    <script async custom-element="amp-vimeo" src="https://cdn.ampproject.org/v0/amp-vimeo-0.1.js"></script>
    <script async custom-element="amp-youtube" src="https://cdn.ampproject.org/v0/amp-youtube-0.1.js"></script>
    <script async custom-element="amp-analytics" src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js"></script>
    <script async custom-element="amp-audio" src="https://cdn.ampproject.org/v0/amp-audio-0.1.js"></script>
    <script async custom-element="amp-carousel" src="https://cdn.ampproject.org/v0/amp-carousel-0.1.js"></script> 
    <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>
    <script async custom-element="amp-video" src="https://cdn.ampproject.org/v0/amp-video-0.1.js"></script>
</head>
	<!-- BEGIN body -->
	<body>
    <header>
  
        <div class="brand-logo">

            <amp-img src="/images/logos/ABN-LOGOchinese-shadow.png" width="85" height="41" layout="fixed"></amp-img>
        </div>
  
    </header>

                                    <div class="content-container">
                <header>
                    <h1 itemprop="headline">AdvanceTC Limited (NSX:A88) Investor Guide Update</h1>
                    <time class="header-time" itemprop="datePublished"
                          datetime="2021-05-14T15:17:00Z">Sydney, May 14, 2021 AEST (ABN Newswire) </time>
                </header>
                                        <div>
                                            
                                            		<div class="author">
			<span><a href="/refer.asp?url=http://www.advancetc.com&compid=37669&lang=" target="_blank"><amp-img src="/images/logos/37669en.png" width="120" height="40" alt=""></amp-img></a></span>&nbsp;
		</div>

                                            
                                        </div>                                       


                                        


                                        <div class="article-body" itemprop="articleBody">

                                        

                                        <div>
                                            
 
                                            <p></p>
                                        </div>
                                            <amp-img class="article-image" src="https://media.abnnewswire.net/topimg/en/103331_01_h.jpg" width=1.77  height=1 layout="responsive"></amp-img>
 <br>
                                            AdvanceTC Ltd (<amp-img src="https://www.abnnewswire.net/images/googlechart.gif" height="12" width="16"></amp-img><a href=//finance.google.com/finance?q=OTCMKTS:ATCLF target=_blank title="OTC Markets Google"><u>OTCMKTS:ATCLF</u></a>) (<amp-img src="https://www.abnnewswire.net/images/googlechart.gif" height="12" width="16"></amp-img><a href=//finance.google.com/finance?q=NSX:A88 target=_blank title="National Stock Exchange (AU)"><u>NSX:A88</u></a>) is pleased to advise that the Company has released an Investor's Guide with FAQ to better guide Investors with Questions that they may have on the Company. The Company shall set up the page on its website in the next few days and shall inform the market once it is ready to be accessed. <br /><br />In the interim, below are some of the common questions raised and the Company's responses to it accordingly. <br /><br />The Investor Guide and FAQ page on the website shall be updated constantly to keep our Investor up to date on the Company's progress. <br /><br />Below are the extract of some of the most commonly asked questions and the Company's responses. <br /><br />In a nutshell, what does your device do that makes it so unique? <br />
We invented a unique Android satellite smartphone which merges multiple channels and methods of communication into one device which we call multimode-communication. We hold a patent, our device is approved by the FCC in the US, we have identified an isolated market which hasn't seen innovation in the lasts 40 years, we innovate relevant services that will only work on our device. This includes, multi-mode communication channels namely GSM, Digital Mobile Radio, Terrestrial Trunked Radio, Push-To-Talk, 4G/5G and of course satellite internet, calling and texting. The range of devices also comes with an integrated emergency button and we provide certain customization options for government. We see growth in offering relevant SaaS, DaaS and carrier services. Those services will be quite unique to our offering and only available in combination with the ownership of this device. <br /><br />What are your past achievements? <br /><br />We were spotlighted in 2012 for the release of the Magic W3 which is a 4.8" Windows(R)7 full OS touchscreen microcomputer with voice call functionality. The Magic W3 provides true windows multitasking, multimedia entertainment, social network connectivity, navigation capability, voice telephony, and the full internet experience. We have successfully built and deployed the world's first Android satellite smartphone with 100% earth coverage . <br /><br />Where does the company manufacture? <br /><br />We manufacture in Kuala Lumpur, Malaysia, and in Toulouse , France. The factory that produces our phones is a shareholder in our company which gives us a perfect strategic alignment. We follow a rigorous value process in our supply-chain to assure the integrity of our brand. <br /><br />How do you see the growth of the sector and in particular the growth of AdvanceTC? <br /><br />As national economies become more global and as we travel across all parts of the continents, the oceans, and the atmosphere the need for effective wireless interconnection via terrestrial wireless and satellite communications will expand. We will continue to innovate services that are relevant to our market and with time increase product inventory so our market share can increase. <br /><br />Another aspect that makes us a possible unicorn is that we are publicly traded which is more attractive to venture capital and investment banks that can potentially accelerate our growth. <br /><br />What are the most critical questions relating to your business? <br /><br />One of the biggest concerns expressed are about our patents held on the existing product and how patents will be registered and enforced for products now in process. The other major concern often raised by investors are related to large established companies or other 5g carriers potentially entering the market and pressuring AdvanceTC out by forcefully inserting similar products in the near future. <br /><br />We are structuring our devices around specific links in the value chain of our industry to remain relevant even after large brand names enter the market. Our growth is focused on marketing our phones and to offer services to enable our clients' communications. <br /><br />We are going to approach the existing satellite phone users once our phone is introduced into the market. The big brand names cannot do that because they don't have our device. There are approximately 1.5 million satellite phone users in the USA alone and they use an outdated phone to make satellite voice calls or to send texts over satellite. We anticipate introducing auxiliary tools to provide communication enabling services that are important to our target markets including multi-mode communication channels integrated into the device, Software as a Service (SaaS), Data as a Service (DaaS) and carrier services. <br /><br />On November 14th 2020 we attended the The National Due Diligence Association (TNDDA) Conference which is for SEC registered broker/dealers, professional due diligence attorneys and investigators and a limited number of high net worth investors. <br /><br />We also attended the 14th Annual LD Micro Conference and we had the chance to address these concerns for the first time publicly. <br /><br />The Satellite communication market is on everybody's map to some degree and there will be exciting innovation in the near future. <br /><br />We believe that the most popular and established global brands will enter this market and we are excited because we fit right in and it will accelerate the development of the sector. <br /><br />How does the future for satellite communications look? <br /><br />The increased utilization of space systems - manned, unmanned, and planetary bodies - will evolve the need for improved space communications systems. Clearly foreseeable technologies suggest that several decades of continuing innovations are now possible. <br /><br />But technology will not be the only source of change for the satellite communications industry. Other drivers of change will include: <br /><br />(a) New service demands in both civilian and defense-related markets;  <br /><br />(b) Restructuring of commercial satellite organizations through acquisition, merger, and regulatory change; <br /><br />(c) New allocations or reallocation of frequencies; <br /><br />(d) Convergence between the various satellite applications markets - both in terms of technology and structural integration; <br /><br />(e) Constraints in orbital configurations; <br /><br />(f) Orbital debris; and even <br /><br />(g) Growth of human activities in outer space may prove to be significant shapers of the growth of satellite systems in the next 20-30 years. <br /><br />In short, there are remarkable new technologies still to be developed in terms of space-based satellite communications systems, more powerful processors, new encoding capabilities, and new user terminal capabilities that can make user systems more mobile, more versatile, more personally responsive, more powerful in terms of performance, and yet lower in cost. <br /><br />There has been a lot of talk about satellite internet and how does AdvanceTC fit into that conversation? <br /><br />Most of the attention has focused on those stories related to the rocket launches getting satellites into space but all of these satellites will need transceivers on Earth to send and receive data. We have a smartphone with satellite capability that has such a receiver built into it. We envision a market where our phone is used by people that need to have access to multiple modes of communication from one device, not just satellite internet. <br /><br />Are you going to provide regular updates to the market? <br /><br />We are committed to provide the market with regular updates and these will mostly be covering our progress with the upcoming launch of our latest device as well as business development activities. We are committed to provide shareholder growth. <br /><br />Where do you see the Company in 12 months? <br /><br />Advanced TC was recently listed as a foreign symbol on the OTC Markets after having spent many years on the Australian NSX Exchange which remains our primary market. Within the coming 12 months we are launching our flagship device and reaching milestones that qualify us for institutional investors, add considerable value to shareholders, and there are plans to list the company on a major exchange in the US as well. We already have strong relationships to move the business forward. <br /><br /><br />About AdvanceTC Limited<br /><br />
AdvanceTC is a premier technology company specializing in the design and development of mobile telecommunication and computing devices. AdvanceTC is listed on NSX Australia (NSX:A88). More information on the company can be found at www.advancetc.com<br /><br /><br />
<p><a href="http://heroes.abnnewswire.com/alerts.asp?art=105409&lang=en&id=37669" target="_blank"><amp-img src="/images/buts/heroes_alert_button.jpg" height="40" width="103"></amp-img></a>&nbsp;</p>
<div>
            <p>Contact</p>
CP Loi <br />Chief Executive Officer <br />Email: loicp@advancetc.com
</div>
<br /><br />
                                                <br />
                                            <div>
                                                <span class="tag">Link:</span> <a href="https://media.abnnewswire.net/media/en/docs/NSX-A88-021739513.pdf" title="Investor Guide Update" target="_blank">Investor Guide Update</a><br /><br />
                                            </div>
                                            

<amp-ad width=auto height=90
    type="adsense"
     data-ad-client="ca-pub-8646679268884814"
     data-ad-slot="1945988928">
</amp-ad>
                                            
                                                <br /><strong>Related Companies</strong><br /><strong><p><a href="https://www.abnnewswire.net/companies/en/37669/AdvanceTC-Limited">AdvanceTC Limited</a><br /></p>
</strong><br />
                                            
                                        <div class="brand-logo">
										    <span><amp-img src="/images/logos/ABN-LOGO-SQ.png" alt="ABN Newswire" width="40" height="40"></amp-img></span>
											<div>
											    <span>&nbsp;<a href="http://www.abnnewswire.com" target="_blank"><b>ABN Newswire Corporate</b></a></span><br />&nbsp;
                                                
                                                <span class="meta">This Page Viewed:<br />&nbsp;&nbsp;(Since Published: 438)&nbsp;</span>
                                                
											</div>
                                        </div>
                                        <div>
										   <p><strong>Related Industry Topics:</strong><br /><a href="#">Wireless</a> <a href="#">E-Commerce and Mobile</a> <a href="#">Financial General</a> <a href="#">IT General</a> </p>
										</div>
                                        							<div class="widget">
								<h3>AdvanceTC Limited</h3>
								<div class="widget-articles">
											<div>
												<a href="/amp/en/105290/"><amp-img class="article-thumb" src="https://media.abnnewswire.net/topimg/en/103331_01_t.jpg" alt="" width="40" height="40"></amp-img></a>
												<h4><a href="/amp/en/105290/">AdvanceTC Limited (NSX:A88) Launch of Multimode Communication App</a></h4>
												<span class="meta">
												</span>
											</div><hr />
											<div>
												<a href="/amp/en/105116/"><amp-img class="article-thumb" src="https://media.abnnewswire.net/topimg/en/103331_01_t.jpg" alt="" width="40" height="40"></amp-img></a>
												<h4><a href="/amp/en/105116/">AdvanceTC Limited (NSX:A88) DWAC/Fast Eligibility Approval from DTC</a></h4>
												<span class="meta">
												</span>
											</div><hr />
											<div>
												<a href="/amp/en/104978/"><amp-img class="article-thumb" src="https://media.abnnewswire.net/topimg/en/103331_01_t.jpg" alt="" width="40" height="40"></amp-img></a>
												<h4><a href="/amp/en/104978/">AdvanceTC Limited (NSX:A88) OTC Market Upgrade</a></h4>
												<span class="meta">
												</span>
											</div><hr />
											<div>
												<a href="/amp/en/104672/"><amp-img class="article-thumb" src="https://media.abnnewswire.net/topimg/en/103331_01_t.jpg" alt="" width="40" height="40"></amp-img></a>
												<h4><a href="/amp/en/104672/">AdvanceTC Limited (NSX:A88) DTC Eligibility Approval</a></h4>
												<span class="meta">
												</span>
											</div><hr />
											<div>
												<a href="/amp/en/103331/"><amp-img class="article-thumb" src="https://media.abnnewswire.net/topimg/en/103331_01_t.jpg" alt="" width="40" height="40"></amp-img></a>
												<h4><a href="/amp/en/103331/">AdvanceTC Limited (NSX:A88) Appointment of Chief Technology Officer</a></h4>
												<span class="meta">
												</span>
											</div><hr />
                                    <br /><a href="/companies/en/37669/">Read More</a>
								</div>
							</div>

    
                                        </div>


									</div>
      

      
                                    <amp-analytics type="googleanalytics" id="analytics1">
                                    <script type="application/json">
                                    {
                                      "vars": {
                                        "account": "UA-381105-4" 
                                      },
                                      "triggers": {
                                        "trackPageview": { 
                                          "on": "visible",
                                          "request": "pageview"
                                        }
                                      }
                                    }
                                    </script>
                                    </amp-analytics>
	</body>
</html>

